FieldRoutes Payments and Knowledge Base Experiencing Outage

Incident Report for FieldRoutes

Resolved

Our third party provider has indicated that services are currently operating normally, and no other issues related to this outage have since occurred within FieldRoutes's platform.
Posted Nov 18, 2025 - 19:37 UTC

Update

We are continuing to monitor for any further issues related to the third-party outage after they have implemented a fix.

Next update: 1:35 CST
Posted Nov 18, 2025 - 17:44 UTC

Update

We are continuing to monitor for any further issues related to the third-party outage after they have implemented a fix.

Next update: 11:35 CST
Posted Nov 18, 2025 - 16:38 UTC

Monitoring

Our third-party provider has implemented a fix. Affected services have started to recover and we are currently monitoring for any further issues.
Posted Nov 18, 2025 - 15:39 UTC

Identified

We’re currently experiencing an outage with several services, including FieldRoutes Payments and the Knowledge Base, due to an outage with a third-party cloud provider. They are continuing to work on a fix for this issue. We apologize for the inconvenience and will post regular updates on our progress.

Next Update - 10:35 CST
Posted Nov 18, 2025 - 14:35 UTC
This incident affected: FieldRoutes (Payments).