Error When Saving Appointments on FieldRoutes Mobile
Incident Report for FieldRoutes
Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 16:15 UTC
Monitoring
The issue has been identified and the developers implemented changes that should resolve the error when saving appointments in FieldRoutes mobile. We are closely monitoring the changes that were made to verify if this issue is fully resolved or if any additional changes need to be made.
Posted Jul 23, 2024 - 21:32 UTC
Investigating
We are actively investigating an issue causing an error when completing appointments for some users on FieldRoutes Mobile. The error message when saving states “There was an error while trying to save. Please try again. Appointment save already in Progress. Please refresh." After refreshing will still get the same message.

The engineering team is actively investigating this issue on high priority and we will continue to share updates as they become available.
Posted Jul 23, 2024 - 15:51 UTC
This incident affected: Mobile (FieldRoutes Mobile).