FieldRoutes Phone System Provider Down

Incident Report for FieldRoutes

Resolved

Our phone system provider has implemented a fix, and we’re currently able to take calls. We’re monitoring the system to ensure continued stability. Thank you for your patience.
Posted Jun 12, 2025 - 21:37 UTC

Investigating

We are currently experiencing an outage with our phone system provider. As a result, FieldRoutes Support is unable to make or receive calls at this time. Note: This does not impact the FieldRoutes software—it remains fully operational. For support, email support@fieldroutes.com. We’ll share updates as soon as more information becomes available. Thank you.
Posted Jun 12, 2025 - 18:46 UTC