A fix has been submitted to both the Apple App Store and Google Play Store for review. We are actively monitoring the approval status and will provide a follow-up update once the updated app versions are confirmed and available for download.
Posted Apr 25, 2026 - 03:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 24, 2026 - 20:19 UTC
Investigating
We are currently experiencing an issue that prevents credit cards from being added within the PestRoutes Sales mobile app. This issue affects FieldRoutes Payments users only and is not impacting other payment methods or user groups.
Our engineering team has been notified and is actively investigating to restore full functionality as quickly as possible. We will provide updates as more information becomes available.
*While our engineering team continues to investigate this issue, we recommend using the FieldRoutes Mobile app as a temporary workaround. We appreciate your patience and will provide an update as soon as a resolution is reached.
Posted Apr 24, 2026 - 18:35 UTC
This incident affects: Mobile (PestRoutes Sales (iOS)).