Recurring Billing & Emailing Invoices Disruptions

Incident Report for FieldRoutes

Resolved

These issues have been resolved. If you have any further questions about these issues, please reach out to support at: support@fieldroutes.com
Posted Oct 16, 2025 - 14:55 UTC

Monitoring

The team has identified the issue and put a fix in place. Recurring billing should be generating successfully now.

If you are still noticing issues please contact: support@fieldroutes.com
Posted Oct 15, 2025 - 21:14 UTC

Investigating

Our team is actively working to resolve an issue that prevented recurring billing from generating as expected. This issue is also impacting other processes such as emailing invoices. 



If you are encountering these issues please email support@fieldroutes.com

Next Update: 3:30pm CST
Posted Oct 15, 2025 - 16:22 UTC
This incident affected: FieldRoutes (Customer Communication - Email, Recurring Billing).